Сервер загрузки, http, ftp, торрент...
#246
К сожалению не помогло...

 
DiskStation> ipkg install gcc_3.4.6-5_powerpc.ipk
Installing gcc (3.4.6-5) to /opt/...
Installing binutils (2.17-2) to /opt/...
Nothing to be done
An error ocurred, return value: -1.
Collected errors:
ERROR: Package binutils (parent binutils) is not available from any configured src.
Failed to download binutils. Perhaps you need to run 'ipkg update'?

Установка binutils из http://ipkg.nslu2-linux.org/feeds/optwa ... /unstable/ тоже проходит с ошибками:
 
DiskStation> ipkg install binutils_2.17-2_powerpc.ipk Installing binutils (2.17-2) to /opt/...
An error ocurred, return value: 7.
Collected errors:
Package binutils wants to install file /opt/bin/ar
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/as
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/ld
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/nm
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/ranlib
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/size
But that file is already provided by package crosstool-native
Package binutils wants to install file /opt/bin/strip
But that file is already provided by package crosstool-native
#247
Удалось установить binutils снеся при этом crosstool-native. И gcc после этого тоже встал. Но опять возникли ошибки при запуске:
.configure --prefix=/opt


 
Checked out revision 1937.
checking for a BSD-compatible install... /opt/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking build system type... powerpc-unknown-linux-gnu
checking host system type... powerpc-unknown-linux-gnu
checking for wininet-config... no
configure: You don't appear to have Wininet installed (no working wininet-config in your command search path), so we will not build the Wininet client XML transport
checking whether to build Wininet client XML transport module... no
checking for curl-config... yes
checking whether to build Curl client XML transport module... yes
checking for libwww-config... no
configure: You don't appear to have Libwww installed (no working libwww-config in your command search path), so we will not build the Libwww client XML transport
checking whether to build Libwww client XML transport module... no
checking whether to build Abyss server module... yes
checking whether to build CGI server module... yes
checking whether to build C++ wrappers and tools... yes
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.


Конкретная ошибка:
 
# gcc --version
Illegal instruction (core dumped)


Похоже, что "обмануть" не удастся. Нужна сборка именно под мой процессор. Судя по тому, что ipkg поставился от 101g, то и сборка gcc, а также binutils и libc-dev нужна под него.
#248
Да, к сожалению обмануть не удастся... компилятор и библиотеки нужны под ваш процессор =(
вот нарыл статью у буржуев, прям ваш вопрос один в один: http://forum.synology.com/enu/viewtopic ... 42&start=0
#251
Супер! Там и ответ был.

Удалил gcc и binutil, и поставил
ipkg install optware-devel


Теперь
 
DiskStation> gcc --version
gcc (GCC) 3.3.4
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Правда при сборке достаточно много предупреждений было, а после входа в rutorrent получил сообщения:
Код: Выделить всё[09.06.2010 15:45:16] WebUI started.
[09.06.2010 15:45:19] ruTorrent не может определить uid пользователя rtorrent. Часть функциональности будет недоступна.
[09.06.2010 15:45:19] autotools: плагин не может стартовать.
[09.06.2010 15:45:19] scheduler: плагин не может стартовать.
[09.06.2010 15:45:19] erasedata: плагин не может стартовать.
[09.06.2010 15:45:19] retrackers: плагин не может стартовать.
[09.06.2010 15:45:19] rss: плагин не может стартовать.
[09.06.2010 15:45:19] trafic: плагин не может стартовать.
[09.06.2010 15:45:19] seedingtime: плагин не может стартовать.
[09.06.2010 15:45:19] unpack: плагин не может стартовать.
[09.06.2010 15:45:19] Пользователю rTorrent не доступна программа 'stat'. Часть функциональности будет недоступна.
[09.06.2010 15:45:20] Плагин ratio: эта версия rTorrent не поддерживает индивидуальное управление ratio. Плагин не будет работать.
[09.06.2010 15:45:20] Плагин throttle: Данная версия rTorrent не поддерживает индивидуальное ограничение скорости закачек. Плагин не будет работать.
[09.06.2010 15:45:22] Bad response from server: (500 [error,list]) Link to XMLRPC failed. May be, rTorrent is down?
[09.06.2010 15:45:22] Плагин autotools: у пользователя rTorrent нет доступа к интерпретатору php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин scheduler: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин DataDir: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин retrackers: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин create: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин rss: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин trafic: пользователю rTorrent не доступен интерпретатор php. Плагин не будет работать.
[09.06.2010 15:45:22] Плагин create: rTorrent должен иметь доступ к программе 'pgrep'. Вы не сможете остановить процесс создания торрента.
[09.06.2010 15:45:22] Плагин rss: пользователю rTorrent не доступна программа curl. Вы не сможете работать с https рассылками.
[09.06.2010 15:45:22] Плагин unpack: Программа unzip недоступна пользователю rtorrent.
[09.06.2010 15:45:22] Плагин unpack: Программа unrar недоступна пользователю rtorrent.
[09.06.2010 15:47:22] Bad response from server: (500 [error,list]) Link to XMLRPC failed. May be, rTorrent is down?
[09.06.2010 15:49:17] Ошибка добавления закачки.


А что это за пользователь rtorrent и с какими правами его заводить?
#252
Тоже удалось запустить rutorrent, но также вылезла куча ошибок о не запуске плагинов. Ставил руками копируя по строке из скрипта и насколько я понял некорректно обработалась часть скрипта где идут команды по изменению параметров в файлах.
Теперь думаю будет ли оно работать стабильно после такой установки и кучи ошибок в плагинах.
UPD
Проверил, интерфейс работает, но закачки добавить не дает, выдает ошибки.
Можно ли удалить следы скрипта и заново его поставить?
#271
Тоже не запускается, причем при переходе на http://nas:5050/rutorrent/ возникает сообщение типа "google chrome не удается отобразить страницу". И к тому же после ребута на мыло пришло оповещение:
"Раздел 1 на NAS поврежден. Возможно, не удастся запустить сервер."
Перезагрузил, прогнал SMART, всё вроде нормально работает, но всё равно страшно. Что могло дать такой эффект?
#272
konst90 писал(а):Тоже не запускается, причем при переходе на http://nas:5050/rutorrent/ возникает сообщение типа "google chrome не удается отобразить страницу".


а почему порт 5050?
lighttpd после установки скриптом стартует на 8081, например так: http://nas:8081/rutorrent/


konst90 писал(а):И к тому же после ребута на мыло пришло оповещение:
"Раздел 1 на NAS поврежден. Возможно, не удастся запустить сервер."
Перезагрузил, прогнал SMART, всё вроде нормально работает, но всё равно страшно. Что могло дать такой эффект?


отказ системного раздела - это вообще загадка для меня... =( у меня один раз было такое... вот тут описал: Отказ системного раздела DS209+